Advertisement:

Template:Party color/doc

From Roovet Articles
Jump to navigation Jump to search

Template:Party color produces the hexadecimal color of the provided political party.

Usage[edit source]

Parameters[edit source]

<section begin="Parameters"/>

Parameter Description
1 The political party's name. If a party is not found, place a request at the talk page.
error Optional, this parameter will return the provided |error= value if the module does not contain the requested party or color.

<section end="Parameters"/>

Examples[edit source]

Here are some examples using the Labour Party (note that there are multiple potential input names):

	["Labour and Co-operative"] = "Labour Party (UK)",
	["Labour Co-operative"] = "Labour Party (UK)",
    ...
	["Labour Party (Thailand)"] = {abbrev = "", color = "#FF0000", shortname = "",},
	["Labour Party (UK)"] = {abbrev = "Lab", color = "#E4003B", shortname = "Labour",},
  • {{Party color|Labour Party (UK)}}Lua error in package.lua at line 80: module 'Module:Political party/L' not found.
  • {{Party color|Labour and Co-operative}}Lua error in package.lua at line 80: module 'Module:Political party/L' not found.
  • {{Party color|Labour Co-operative}}Lua error in package.lua at line 80: module 'Module:Political party/L' not found.

Error messages[edit source]

If the party is not supplied, or the color is not stored for the party, an error will be returned. Note that if the party is not in the module at all (third example below) the default color #F8F9FA will be returned.

  • {{Party color}}parameter 1 should be a party name.
  • {{Party color|A test no values}}Lua error in package.lua at line 80: module 'Module:Political party/A' not found.
  • {{Party color|Not-a-party}}Lua error in package.lua at line 80: module 'Module:Political party/N' not found.

To avoid generating a script error, use |error=value. Note that this error value will also be passed if the party is not stored in the module.

  • {{Party color|A test no values|error=ERROR}}Lua error in package.lua at line 80: module 'Module:Political party/A' not found.
  • {{Party color|Not-a-party|error=ERROR}}Lua error in package.lua at line 80: module 'Module:Political party/N' not found.

See also[edit source]